Echo State Network

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Echo State Network

Steve
Hello,

i just tried to create an Echo State Network with Simbrain. Via: > Insert > Insert Network > Echo State Network
The ESN creation dialog appears and I clicked ok without changing any predefined settings in this dialogue. Then a small window appears stating: “BUILD FAILURE: One or more entered parameters are invalid. Check all fields for invalid variable assignments.”
Then I tried to change several settings but I always got the error message.
Can somebody give me a hint how to setup a ESN in a correct way ?
Regards
Steve
Reply | Threaded
Open this post in threaded view
|

Re: Echo State Network

jyoshimi
Administrator
Hi there,

I wasn't able to replicate this. When I click through in the current Simbrain and add an ESN, it shows up fine for me.  That error means something happened like strings were put in a field meant for numbers.  If this is still occurring for you you could take a screenshot of the dialog just before you click ok.

Also, there is a slight chance this is related to localization, e.g. if you are using this with a German localization. If you are using it in some other locale besides the US/UK, let me know.

- Jeff
Reply | Threaded
Open this post in threaded view
|

Re: Echo State Network

Steve
Hi Jeff,
Here several additional details about the situation:
1. I use Windows 7 SP1
2. Local setting is Germany
3. Simbrain 3.02
4. Java 1.8
5. Screenshots




After the ESN creation dialog appears I did not change any predefined settings and press ok – after appr. 1 second the error message appears (screenshots) and a window opens containing a matrix with 256 neurons (screenshots).
I tried to change the local settings to UK and US – still the same situation.
I tried it out on another computer (same OS, settings and versions as above) same error again.
Then I started the Windows console and started Simbrain via “java –jar simbrain.jar”. Same error, after ending Simbrain the console shows several messages:

“Warning: could not open/create prefs root node Software\Javasoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(…) returned error code 5.
Log4j: WARN no appenders could be found for logger (org.simbrain.workspace.Workspace).
Log4j: WARN please initialize the log4j system properly.
Java.lang.IllegalArgumentException: termoverflow at umentreal.iro.lecuyer.probdist.BinomialDist.prob(BinomialDist.java:314)” and a lot of subsequent messages.
I hope these information help to identify the problem – many thanks in advance
Best Regards
Steve

Reply | Threaded
Open this post in threaded view
|

Re: Echo State Network

Steve
Hi Jeff,

agian i changed the local settings of Windows to US settings, rebooted the computer and now it works perfect.
Many thanks for this great software.
Best Regards
Steve